Back to overview
Degraded

Ongoing DDoS

Feb 27 at 07:08pm CET
Affected services
mafiamatrix.com

Resolved
Feb 27 at 10:45pm CET

Traffic has normalized. Marking the incident as resolved pending further developments.

Created
Feb 27 at 07:08pm CET

We're experiencing an ongoing DDoS attack. We've upped Cloudflare's aggressiveness but until the perpetrator realizes how petty they are, there'll be ups & downs in terms of availability!